Quay.io continuing to experience some minor issues following recent maintenance.
Incident Report for Quay.io
Resolved
Quay.io is operating regularly now, please feel free to raise a ticket with our support teams for any further issues you encounter.
Posted Mar 08, 2022 - 15:33 EST
Update
Bitbucket Build Triggers are now operational
Posted Mar 08, 2022 - 09:42 EST
Update
We are continuing to monitor for any further issues.
Posted Mar 07, 2022 - 13:23 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2022 - 14:23 EST
Update
Scan results on newly pushed images are now appearing within expected timeframes.
Posted Mar 04, 2022 - 14:22 EST
Update
The endpoint https://recovery.quay.io is now operational and can be used to set up Red Hat SSO or recover your quay.io password.
Posted Mar 04, 2022 - 11:44 EST
Update
There is a known issue with setting up Red Hat SSO accounts on https://recovery.quay.io. We are investigating currently and will resolve as soon as possible.
Posted Mar 04, 2022 - 07:43 EST
Update
Builds should be operating normally now. Scan result times for new images should be improved however we will continue to review feedback for another day as our backlog clears.
Posted Mar 02, 2022 - 17:07 EST
Update
Some customers may continue to experience timeouts on large container build tasks. In addition, we continue to work on reducing the overall time for security scan results to appear- thank you for your patience while we continue to work on fully restoring these services.
Posted Mar 01, 2022 - 17:15 EST
Update
We're continuing to work on improving security scanning response times for new image pushes.
Posted Feb 25, 2022 - 16:58 EST
Update
Security scan details for older images should now be available, we are continuing to work on improving our response time for scan results on newly pushed images as well as handling timeouts on longer running container builds.
Posted Feb 24, 2022 - 17:46 EST
Update
The excessive rate limiting issue has been addressed however you may still experience normal rate limiting going forward. Long running container builds may occasionally timeout and need to be resubmitted. Security scans may take longer than expected to process as we work through our backlog. Scan results on older images may not show vulnerability details, please re-push the image to see the details.
Posted Feb 23, 2022 - 18:05 EST
Update
Customers may experience rate limiting (429 responses) on registry requests (both pushes and pulls)- the Quay engineering team is aware of this issue and is currently investigating.
Posted Feb 23, 2022 - 10:26 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 22, 2022 - 16:37 EST
Update
We have identified an issue with builds potentially not completing and are investigating. We are also investigating sporadic 429 responses on pushes.
Posted Feb 22, 2022 - 11:55 EST
Update
Quay Builders are now up and running. The Clair security scanner will remain down until tomorrow.
Posted Feb 21, 2022 - 17:35 EST
Identified
Clair will be enabled shortly; Quay Builder will be enabled after that.
Posted Feb 21, 2022 - 14:48 EST
Update
We are continuing to investigate this issue.
Posted Feb 20, 2022 - 11:22 EST
Investigating
In order to allow for monitoring of the newly upgraded quay.io, Quay Builder and Clair security scanner will remain disabled until Monday, February 21, 2022.
Posted Feb 20, 2022 - 11:22 EST
This incident affected: Build System, Security Scanning, and Atlassian Bitbucket Webhooks.