DB connection spike
Incident Report for Quay.io
Resolved
No further incidents have occurred since the last change. We will continue the investigation tomorrow.
Posted about 1 month ago. Apr 17, 2019 - 00:57 EDT
Update
When we tried to re-enable the bad namespace, it caused an immediate database lockup. We've re-disabled the namespace and are awaiting the database to return to normal operation.
Posted about 1 month ago. Apr 16, 2019 - 14:04 EDT
Update
We are currently deploying a code change that we hope mitigates this issue for the near term future. We will be monitoring this deployment and will rollback if any issues occur.
Posted about 1 month ago. Apr 16, 2019 - 13:40 EDT
Update
As we continue to monitor an earlier db connection spike Quay.io users may experience intermittent service interruptions or ongoing performance degradations throughout the day.
Posted about 1 month ago. Apr 16, 2019 - 12:01 EDT
Update
We are continuing to monitor for any further issues.
Posted about 1 month ago. Apr 16, 2019 - 10:12 EDT
Update
We are continuing to monitor for any further issues.
Posted about 1 month ago. Apr 16, 2019 - 10:11 EDT
Monitoring
Monitoring DB
Posted about 1 month ago. Apr 16, 2019 - 10:11 EDT
Investigating
After a config change that rolled out new features to a subset of users, the database is under higher load than normal and causing problems for the registry and API.
Posted about 1 month ago. Apr 16, 2019 - 08:38 EDT
This incident affected: Registry, API, and Build System.