GitHub Trigger Setup permissions issue
Incident Report for Quay.io
Resolved
We've deployed a fix to bypass the GitHub permission indicator returned by their API, which should allow for creation of triggers
Posted Mar 26, 2020 - 17:37 EDT
Identified
Due to an apparent change in the GitHub API response around repository permissions, Quay is showing "Admin permissions required" for creating triggers on certain GitHub repositories, despite users having said permissions on those repositories. We've reached out to GitHub to determine the root cause.

As a workaround, users can grant themselves explicit admin access on the GitHub repository for which they wish to add a build trigger. We are also currently investigating a hotfix change on our end to remove this check temporarily.
Posted Mar 26, 2020 - 12:28 EDT
This incident affected: GitHub.